Service Disruption affecting Connect
Incident Report for Firstup
Resolved
The service disruption affecting email campaigns has been resolved. Please note email metrics will be delayed but should be up to date in the next 30 minutes.

Thank you for your patience whilst we carried out our investigation. Please contact Support at support@socialchorus.com should you encounter any further issues.
Posted May 09, 2022 - 18:57 UTC
Monitoring
We have applied a fix for the issue affecting delayed email campaign sends and are currently monitoring.
Posted May 09, 2022 - 18:47 UTC
Identified
We are investigating a service disruption where email campaign sends are delayed. This issue will be noticed if email campaigns are scheduled to send during this time.

Our next update will be in 30 minutes.
Posted May 09, 2022 - 18:28 UTC
This incident affected: Ecosystem (Connect).