Analyze - Select reports are not loading as expected
Incident Report for Firstup
Resolved
The issue affecting some Analyze reports from loading has been resolved.

Thank you for your patience whilst we carried out our investigation. Please contact Support at support@socialchorus.com should you encounter any further issues.
Posted Nov 23, 2020 - 17:48 UTC
Identified
We have identified a possible root cause for the issue affecting some Analyze reports from loading and will provide further updates once we have applied a fix.
Posted Nov 23, 2020 - 17:22 UTC
This incident affected: Products (Analyze).