Android - Apps not showing in the Google Play Store
Incident Report for Firstup
Resolved
All affected mobile applications have been restored to the Google Play Store.
Posted Jan 10, 2020 - 01:52 UTC
Update
Google Play Store is beginning to publish mobile applications which have been affected by this issue. We are continuing to monitor this issue as mobile apps publish.

Anyone who has the application downloaded will remain unaffected by this issue. Only those new users who have not downloaded the mobile application will be affected until Google is able to finish re-publishing all applications to the Play Store.
Posted Jan 09, 2020 - 22:29 UTC
Update
We are continuing to monitor this issue. Our team is communicating with Google as the app approval process proceeds.
Posted Jan 09, 2020 - 21:00 UTC
Update
Update - We have resubmitted the affected apps and Google has confirmed the apps will be approved and begin to reappear within the Play Store momentarily
Posted Jan 09, 2020 - 16:31 UTC
Monitoring
We have identified an issue causing some Android apps to not show in the Google Play Store. We have determined the root cause and are working on a fix to restore the apps. We'll provide further updates as soon as we have them.
Posted Jan 09, 2020 - 15:13 UTC
This incident affected: Products (Mobile Experience).